Easy Starting but dies when given throttle

Information relating to the Matchless G12 or AJS Model 31 650cc twin
Member
Posts: 31
Joined: Thu Nov 21, 2013 3:05 am
Location: Perth Australia

Easy Starting but dies when given throttle

Postby PeterJCorby » Tue Aug 07, 2018 11:00 am

Hello,
I have finally gotten round to starting my G12 63. I have a clean tank, new plugs and leads and a complety restored Mag, points and condensor.Also a brand new AMAL Mono Block with Stock setup. Fresh fuel and oil. Tickled the carb and the bike started on the second kick. After warming up I advanced the timing and then blipped the throttle. I was rewarded with a backfire and a stalled motor. Kicked her again and off she goes with one kick. Idles beaut, set the carb air screw 1 and half turns as suggeseted, Gave her some throttle and she sputters and farts away , tries to rev up and fails. When u do get her to rev slightly, as soon as u open the trottle she battles and dies.

Any Suggestions will be much appreciated. After taking the past 5 years putting her together I'd like to get her out on the road.

Member
Posts: 180
Joined: Tue Oct 24, 2017 11:05 am
Location: DEVON UK

Re: Easy Starting but dies when given throttle

Postby MalcW » Tue Aug 07, 2018 11:12 am

Hi Peter

It sounds like it's running too lean. What's your choke setting at the time - it could be worth giving it more choke for a bit. Also, is it possible that you have an air leak between the manifold and head, or carb and manifold? Could the carburettor top be loose or cross threaded?

Malc

Member
Posts: 31
Joined: Thu Nov 21, 2013 3:05 am
Location: Perth Australia

Re: Easy Starting but dies when given throttle

Postby PeterJCorby » Tue Aug 07, 2018 11:17 am

I actually have not installed the choke slide as the cable for it needs replacing. Actually the only thing I can think of where there may be air getting in is through the hole in the Carb top where the cable for the Choke goes? Possible this could affect it?

I let the bike warm up for a good 5 mins before trying to blip the throttle.No excess smoke or anything else noticed. Wondering if the jet size provided with the new carb is wrong. I had matched it to what was in her before ordeing, so was hoping that would be fine.

Member
Posts: 95
Joined: Sun Sep 19, 2010 9:17 am
Location: NEW ZEALAND

Re: Easy Starting but dies when given throttle

Postby McBob » Tue Aug 07, 2018 11:54 am

I have removed the choke from mine and blanked the cable hole. Seems your running fine on the pilot circuit then as you suggest leaning out when the throttle is opened because of the hole in the top of the carb, you could block that up and see how it runs.

blanking screw http://www.jampot-spares.com/store/comersus_viewItem.asp?idProduct=22062

Member
Posts: 1187
Joined: Thu Jul 04, 2002 12:00 am
Location: NORMANDIE FRANCE

Re: Easy Starting but dies when given throttle

Postby Groily » Tue Aug 07, 2018 12:15 pm

I know this sounds totally daft when you have a brand new carb there - but I have had the same problem with a brand new 389, drove me mad, and the cure was to fit an old needle jet and ignore the fact it will have been a bit worn probably. Instant fix, and still doing fine 5 years later.

It was someone on another forum who suggested it to me, having had the same thing too with a brand new carb . . . So, just maybe, there is something in it rather than bar-room bullshit!

Also, very well worth checking there is no air leak on the inner joints of the inlet manifold. The gaskets there are thin, and the parts can get a bit 'off' over time. Had that too.

I may have been unlucky, but so far I have never managed to fit a brand new carb and get 'perfect' straight out of the box.

Member
Posts: 31
Joined: Thu Nov 21, 2013 3:05 am
Location: Perth Australia

Re: Easy Starting but dies when given throttle

Postby PeterJCorby » Tue Aug 07, 2018 12:27 pm

Thanks Folks,

Will seal that hole and as i still have the old complete carb, which besides looking rather old, isnt that worn in the slide department. May just fit the old one and see how that goes. And if not , then use the main jet as mentioned. It is a bit of a bugger as I was hoping the new would be better. Will be really happy and confused if the old works better. Will keep u posted. Its a bit late over here in Perth, but I will get round to it soonish and report back.

Member
Posts: 935
Joined: Mon Mar 24, 2014 5:44 pm
Location: Aberdeenshire

Re: Easy Starting but dies when given throttle

Postby Mick D » Tue Aug 07, 2018 12:55 pm

Hi

It sounds a bit too 'dramatic' to be caused by an air leak, which I'd expect to result in poor pick up or misfire / spit back.

If the engine is shutting down I'd check that the main jet is clear and that the timing is advancing correctly.

Regards Mick

Member
Posts: 282
Joined: Thu Jan 01, 1998 12:00 am
Location: FYN DENMARK

Re: Easy Starting but dies when given throttle

Postby Ib-Denmark » Tue Aug 07, 2018 3:22 pm

PeterJCorby wrote:Thanks Folks,

Will seal that hole and as i still have the old complete carb, which besides looking rather old, isnt that worn in the slide department. May just fit the old one and see how that goes. And if not , then use the main jet as mentioned. It is a bit of a bugger as I was hoping the new would be better. Will be really happy and confused if the old works better. Will keep u posted. Its a bit late over here in Perth, but I will get round to it soonish and report back.


Years ago on my G80 i sealed that hole with a screw.
I later found that damned screw between the inlet valve and the seat :oops:
Nothind damaged, but better be safe than sorry and secure the sealing plug.
No one to blame but me. -Well I was very young then ;)
Ib

Member
User avatar
Posts: 206
Joined: Mon Jan 01, 1990 12:00 am
Location: WILTSHIRE UK

Re: Easy Starting but dies when given throttle

Postby les ward » Tue Aug 07, 2018 3:27 pm

I had a similar experience with a new carb on my 1961 650.
It was fitted with a 4 slide (correct according to the manual). I changed to a 3.5 (ipad can't cope with digits for 3and a half). That cured the problem for me.

Member
User avatar
Posts: 2144
Joined: Mon Oct 05, 2009 12:00 am
Location: ESSEX UK

Re: Easy Starting but dies when given throttle

Postby 1608 » Tue Aug 07, 2018 3:43 pm

Have you considered the HT side of things. If the HT leads, caps etc are tracking, the symptoms you describe will worsen as the load increases.
My new 389Amal came with the wrong ( under-sized ) jet block reducing the intake bore diameter. As the old carb only had a distorted body I swapped the jet blocks over as could't be bothered to send the new one back.

Next

Return to G12 / AJS Model 31

Who is online

Users browsing this forum: No registered users and 2 guests